{"_id":"57818315c478350e00d5c868","category":{"_id":"57590727ace5c30e00cb23d8","__v":0,"version":"57590727ace5c30e00cb23d7","project":"571193ce8103870e00f48b67","sync":{"url":"","isSync":false},"reference":false,"createdAt":"2016-04-16T01:22:22.642Z","from_sync":false,"order":0,"slug":"documentation","title":"Documentation"},"githubsync":"","version":{"_id":"57590727ace5c30e00cb23d7","__v":2,"project":"571193ce8103870e00f48b67","createdAt":"2016-06-09T06:05:27.924Z","releaseDate":"2016-06-09T06:05:27.924Z","categories":["57590727ace5c30e00cb23d8","57590cd318760817001e8a83"],"is_deprecated":false,"is_hidden":false,"is_beta":false,"is_stable":true,"codename":"","version_clean":"4.0.0","version":"4.0.0"},"user":"571193c63590a50e00bba99d","__v":2,"project":"571193ce8103870e00f48b67","updates":[],"next":{"pages":[],"description":""},"createdAt":"2016-07-09T23:04:53.804Z","link_external":false,"link_url":"","sync_unique":"","hidden":false,"api":{"results":{"codes":[]},"settings":"","auth":"required","params":[],"url":""},"isReference":false,"order":999,"body":"DiscordPHP has minimal requirements, however there are some basic ones.\n[block:parameters]\n{\n  \"data\": {\n    \"h-0\": \"Name\",\n    \"h-1\": \"Description\",\n    \"h-2\": \"Type\",\n    \"0-0\": \"PHP 5.6+\",\n    \"0-1\": \"The PHP executable, must be above version 5.6. We recommend PHP 7.x+ as PHP 5.x will be removed eventually.\",\n    \"1-0\": \"Composer\",\n    \"1-1\": \"Any version of Composer should work fine. Composer will install the other requirements. Check it out [here](https://getcomposer.org).\"\n  },\n  \"cols\": 2,\n  \"rows\": 2\n}\n[/block]\nThe [Voice Client](doc:voice-client) has some extra requirements:\n[block:parameters]\n{\n  \"data\": {\n    \"h-0\": \"Name\",\n    \"h-1\": \"Description\",\n    \"0-0\": \"FFmpeg\",\n    \"0-1\": \"FFmpeg is required to convert the audio files to PCM16. Check it out [here](https://ffmpeg.org).\",\n    \"1-0\": \"libsodium\",\n    \"1-1\": \"The libsodium library is required to encode/decode the audio that is sent/received. Check it out [here](https://download.libsodium.org/libsodium/content/installation/).\",\n    \"2-0\": \"libsodium-php\",\n    \"2-1\": \"libsodium-php is a PHP wrapper for the libsodium library.\",\n    \"3-0\": \"glibc 2.14 (CentOS only)\",\n    \"3-1\": \"CentOS does not come with glibc 2.14 by default, follow [this guide](http://unix.stackexchange.com/questions/176489/how-to-update-glibc-to-2-14-in-centos-6-5) to install 2.14 alongside your original version.\"\n  },\n  \"cols\": 2,\n  \"rows\": 4\n}\n[/block]","excerpt":"","slug":"requirements","type":"basic","title":"Requirements"}
DiscordPHP has minimal requirements, however there are some basic ones. [block:parameters] { "data": { "h-0": "Name", "h-1": "Description", "h-2": "Type", "0-0": "PHP 5.6+", "0-1": "The PHP executable, must be above version 5.6. We recommend PHP 7.x+ as PHP 5.x will be removed eventually.", "1-0": "Composer", "1-1": "Any version of Composer should work fine. Composer will install the other requirements. Check it out [here](https://getcomposer.org)." }, "cols": 2, "rows": 2 } [/block] The [Voice Client](doc:voice-client) has some extra requirements: [block:parameters] { "data": { "h-0": "Name", "h-1": "Description", "0-0": "FFmpeg", "0-1": "FFmpeg is required to convert the audio files to PCM16. Check it out [here](https://ffmpeg.org).", "1-0": "libsodium", "1-1": "The libsodium library is required to encode/decode the audio that is sent/received. Check it out [here](https://download.libsodium.org/libsodium/content/installation/).", "2-0": "libsodium-php", "2-1": "libsodium-php is a PHP wrapper for the libsodium library.", "3-0": "glibc 2.14 (CentOS only)", "3-1": "CentOS does not come with glibc 2.14 by default, follow [this guide](http://unix.stackexchange.com/questions/176489/how-to-update-glibc-to-2-14-in-centos-6-5) to install 2.14 alongside your original version." }, "cols": 2, "rows": 4 } [/block]